Seagate HDD Not Showing Up

I have a 4TB external hard drive. I have removed the casing and the chip, and plugged a SATA to USB connector into it. The hard disk starts for about 10 seconds, I can hear a repetitive pattern involving a couple of clicks. It’s repetitive so I presume it’s attempting to do something but something mechanical is stopping it from going any further; then when the machine realises it’s not getting anyway, it powers off. My Mac detects a device, but I suspect this is the boot drive on the HD as the volume is only 4gb, and it’s not initialized. There’s about 1TB of data stored on it – just photos. We need them recovering please, could you please provide a quote, and whether I would need to provide an empty hard drive for the data to be recovered onto?
Other than using Disk Utility on Mac, I have also tried to access the drive through Ubuntu, and DiskWarrior. Neither work. The hard drive does not spin, other than for the initial 10 or 15 seconds or so.
The make of the hard disk is Seagate: Backup Plus (4TB) – it’s a 2.5″ SATA and is just not showing up.
I have taken the case enclosing off it already.

seagate hdd

When I connect my hard drive to my mac laptop the blue light flashes continuously and you can hear it making a sound however, the laptop no longer recognises it. I have plugged in into another laptop and a desktop and the same thing happens. I also tried restarting my laptop etc.
It did drop out from my mac desktop and has been like this since. Desperate to recover all data on this hard drive. Could I have a little more info on your pricing and what is involved.

I have a small Seagate external hard drive. The computer recognises powers up the hard drive but is unable to see the patchway or read files. The drive keep making the same clicking noise.

4Tb Seagate:
The message came up: ‘The disk structured is corrupted and unreadable’.
I have run a chkdsk and a recovery programme. The files are there but I can’t access them.
Any help you can provide would be appreciated